Delayed background processing and workspace provisioning

Incident Report for Orchestry

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 22:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2026 - 21:28 UTC

Identified

We have confirmed the cause of the background processing delays and are working towards a fix. Affected job servers are being restarted along with a temporary mitigation to restore throughput while we finalize the fix.
Posted Aug 17, 2026 - 17:34 UTC

Investigating

We are experiencing delays in background processing across all regions. Some customers may see workspace provisioning and reporting data updates take longer than usual or appear stuck in progress. The Orchestry app itself remains available. We have identified the cause and are working on remediation. No data has been lost, delayed work will complete once processing recovers.
Posted Aug 17, 2026 - 14:26 UTC
This incident affected: Provisioning and Lifecycle.